Okay, so i was working on a game in developement for the past year, and i have made a lot of progress. I had just finished adding an mp3 file to play during gameplay and decided to test the game. I clicked the test button and the loading bar appeared but it never finished loading, it just stayed stuck on the loading bar. I checked task manager and it said the program was not responding. I terminated it and it brought me back to gm so i saved the game and rebooted gm. Gm wouldn’t load my game though, the loading game files window appeared but then i only got up to 2 bars of the loading bar filled up. I can’t load my game anymore and i even tried reinstalling gm but i get the same thing, can anyone help?

try something that isnt an MP3
like a midi

i would but i can’t get the game file to load up.

oh xD
well then
i dont know =/

Ouch, sounds like your game file may be corrupted… Did you save any backups at all?

i did but i really made a lot of progress since, and i don’t think i’ll have the patience to redo about 3 months work, if i send you the file could you try to fix it?

can you load the backups?

yes, but the percentage of game completeion in the backups is about 5% finished the corrupt file is about 80% finished

that is some major suckage
shouldve backed up more


i dunno if its possible to UNcorrupt a file

This may sound silly but, have you tried restarting your computer? If a game file is corrupt, generally Game Maker would let you know, instead of sitting at the loading bar for an age. It sounds to me like the problem is computer-related. What version of GM are you using, and how large was the mp3 file?

I find it quite surprising that the only game backup is at 5% completion. That pretty much means you did about 75% of the work without saving it once, unless you switched GM’s auto-backup off or something. Again, try restarting your computer if you haven’t, and if it’s in an older version of GM, try opening the file in a newer version.

You can send me the file and I’ll see if my Pc can open it or not.

okay, i’ll outline everything that may relate to the problem.

1:old ass computer, it’s a pentium 3 but it’s running a hacked windows xp proffesional, and i’m low on disk space.

2:i’m using a hacked pro version of gm7

3:the mp3 i’m using was made in a full version of mixcraft 4(hacked) and the size is about 1.3 megabytes.

4: I know, i hack a lot.

i sent you the file, dragon

ps. i didn’t know of an auto backup feature, how do i access this?

EDIT: Never Mind, I Figured Out How To Find The Backups And Now My Problem Is Solved. Thanks Guys!

pss. You will all find a demo sitting in your inboxes!

btw, if anyone would like to help make the game, i’ll start a topic for it.

Oh Crap! sorry for the double post but i need help again! I managed to get the backup working so i saved it over the old file just to be safe. I made a copy of the file and put in my c directory as a backup of my own. I decided to see if i could get the game to work with the same mp3 but it didn’t and heres the catcher: I didn’t save the file so that it would be the way before i tried adding the song again and then i got the same problem! I tried reloading the file but it didn’t work, i tried to reload the backup that gm automatically made but it didn’t work either, finally as a last attempt, i tried loading the backup i had put in the c drive.I hadn’t even touched that one and yet it wouldn’t work! I’m so frustrated. I tried with the legit gm(7.0) and even with the older version (6.1). i got the same effect for 7.0 but 6.1 couldn’t even find the files. I tried opening the file with right click,open program with: and attempted to select gm 6.1 but it wouldn’t appear in the list or even do anything. I think my game is screwed and i really need help here.

For christ’s sake.

GM6 won’t open GM7 files, now, will it?

No, it won’t. They have completely different file extentions, and you probably shouldn’t try changing .gmk’s to .gm6’s regardless.

Well, the old computer thing could have something to do with it. I remember an error I used to get in GM on my old 2000 desktop running XP Pro: “An unexpected error has occurred.” The most undescriptive and annoying end-runtime error I’ve ever seen in any program :stuck_out_tongue:. It wouldn’t fix until I closed and re-opened all GM’s, and often I just plain had to restart my computer.

I’d suggest not trying to add that mp3 anymore, assuming you can get a running version of your game back. Try removing the mp3, if you haven’t. It’s possible that your computer’s older sound card doesn’t like the way GM7 is trying to handle it, or something… shrugs

Might as well post that I tried to run your game file, but it wouldn’t get past the start up loading screen for me. It seems like Game Maker froze and wouldn’t respond.

T’would be a shame if it were forever corrupt. I played through the demo you sent - not bad :stuck_out_tongue:. While nothing’s amazing by any means, I always like a bit of a thinking challenge, which you have somewhat of a knack for it seems. That, and level design. The room full of tons of falling platforms had a funny solution, heheh :slight_smile:.

if the demo is recent then [snip] could help

edit: actually maybe I should pm it. <_<

i dont even know how to use it anyway xD

how do i run the decompiler? all i got was a bunch of random files.